[etherlab-users] r8169 driver for 2.6.38 kernel

Shahbaz Youssefi shabbyx at gmail.com
Wed Feb 27 15:27:19 CET 2013


Hi,

I would like to ask whether anyone has the patch for r8169 driver for the
2.6.38 kernel? In the repository, up to 2.6.37 is supported and then jumped
to 3.0.

2.6.38 is, until RTAI catches up with 3.*, the latest kernel supported by
RTAI and it would be nice if we had ethercat drivers for it too.

I tried applying the diff between the orig and ethercat versions of the
driver for 2.6.37, on the driver of 2.6.38 and fixed the conflicts, which
were rather trivial. However, starting the ethercat master results in many
timeouts, mismatches, errors and failures of all sorts, which leads me to
believe that simply applying the diff to the newer driver hadn't been
enough.

Even if not officially supported, perhaps someone here has already fixed
the driver for his own use. In that case, would you please share it? If
not, would the developers take (possibly small) time to come up with the
driver?

Thank you,
Shahbaz
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.etherlab.org/pipermail/etherlab-users/attachments/20130227/93c8f52c/attachment.htm>


More information about the etherlab-users mailing list