[etherlab-users] Adding etherlab to yocto image

Çağatay Yürük cagatay.yuruk at altinay.com
Mon Apr 29 15:23:57 CEST 2019


Hello everyone,

 

I am newbie to yocto project. I want to use etherlab ethercat master in our
system. System image created with Yocto 2.5.3.

 

What I did so far;

 

I created a recipe file addetherlab with source file;

 

# Recipe created by recipetool

# This is the basis of a recipe and may need further editing in order to be
fully functional.

# (Feel free to remove these comments when editing.)

 

# WARNING: the following LICENSE and LIC_FILES_CHKSUM values are best
guesses - it is

# your responsibility to verify that the values are complete and correct.

#

# The following license files were not able to be identified and are

# represented as "Unknown" below, you will need to check them yourself:

#   devices/e1000/LICENSE

#

# NOTE: multiple licenses have been detected; they have been separated with
&

# in the LICENSE value for now since it is a reasonable assumption that all

# of the licenses apply. If instead there is a choice between the multiple

# licenses then you should change the value to separate the licenses with |

# instead of &. If there is any doubt, check the accompanying documentation

# to determine which situation is applicable.

LICENSE = "LGPLv2.1 & GPLv2 & Unknown"

#LIC_FILES_CHKSUM =
"file://COPYING.LESSER;md5=4fbd65380cdd255951079008b364516c \

#                    file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \

#
file://devices/e1000/LICENSE;md5=e2643b73e47fa4b29cdfad24ee42bed6"

 

# No information for SRC_URI yet (only an external source tree was
specified)

SRC_URI = ""

 

# NOTE: if this software is not capable of being built in a separate build
directory

# from the source, you should replace autotools with autotools-brokensep in
the

# inherit line

inherit autotools

 

# Specify any options you want to pass to the configure script using
EXTRA_OECONF:

EXTRA_OECONF = ""

 

Then I added this recipe to local.conf file. When I want to build image I
get this error;

 

Log data follows:

| DEBUG: SITE files ['endian-little', 'common-linux', 'common-glibc',
'bit-64', 'x86_64-linux', 'common']

| DEBUG: Executing shell function do_compile

| NOTE: make -j 4

| make: *** No targets specified and no makefile found.  Stop.

| ERROR: oe_runmake failed

| WARNING: exit code 1 from a shell command.

| ERROR: Function failed: do_compile (log file is located at
/home/cyuruk/build/tmp/work/corei7-64-poky-linux/addetherlab/0.1-r0/temp/log
.do_compile.59568)

 

Is anybody use etherlab with yocto created image. What is the correct way to
use etherlab with yocto created linux image

 

Thanks

 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.etherlab.org/pipermail/etherlab-users/attachments/20190429/a7ef13de/attachment.html>


More information about the etherlab-users mailing list