[etherlab-users] rc.status missing on Debian Linux

Florian Pose fp at igh-essen.com
Wed May 30 17:51:22 CEST 2007

Hi Hans,

On Tue, May 22, 2007 at 12:15:52PM +0100, Hans Muehlbauer wrote:
> I am just starting to work with Linux, and EtherCat and I am wondering if
> someone within this group can help me solving a very stupid problem.

no problems are stupid... ;-)

> I started with a live CD from RTAI based on a Knoppix/Debian Linux operating
> system. On the first view this worked fine and after some minor problems I
> could make a new LINUX-kernel which is working. Then I tried to install the
> EtherCat Master protocoll stack from IGH. 
> Unfortunately, when starting the ethercat script in /etc/init.d this script
> is looking for another script called rc.status. My problem is now that this
> is not available on a Debian/Knoppic based Linux.

My colleague had the same problem: Unfortunately, Debian does not conform to
the Linux Standard Base (LSB) in this case. Commenting out all appearances of
"rc.*" with a '#' before it in /etc/init.d/ethercat, should solve the problem.


More information about the Etherlab-users mailing list