[etherlab-users] generic driver generally not working

Fabian Herb fabian.herb at indurad.com
Thu Apr 8 19:24:08 CEST 2010

Am Donnerstag 08 April 2010 13:35:47 schrieb Mladen Knezic:
> Hi,
> >Is there anything I have to do besides setting DEVICE_MODULES="generic"?
> Probably stupid question but have you compiled EtherCAT Master for generic
> driver module (i.e. have you configured EtherCAT Master with the generic
>  driver option)?
> ./configure --with-linux-dir=/path/to/linux/src --enable-generic=yes
> Is the driver module loaded when master is running? What dmesg says?
> Best regards,

This is not a stupid question, I'm glad for any hint. However I did compile 
the generic module before.

Now I removed two slaves and it works! I readded them and it still works. 
Yesterday I tried the whole day to no avail. I'll let you know if it works 
tomorrow. Right now I have no idea why it works or why it didn't. Maybe there 
was a physical problem, and the native driver did not care.

On a different machine there seems to be a problem with mixing a 64 bit kernel 
with 32 bit userspace, but that won't be limited to the generic driver, and 
this setup is not so important.

A third machine where the generic driver failed is not available to me 
anymore. The native e100 driver worked on the same interface.

Thanks for your time,

Fabian Herb
Embedded Software Development

indurad GmbH
The Industrial Radar Company

Lochnerstrasse 4-20
52064 Aachen, Germany
Tel: +49 241 80 968 71

fabian.herb at indurad.com

More information about the Etherlab-users mailing list