[etherlab-users] configuring servo drives via EoE?

Georg Sassen gsassen at batalpha.com
Thu May 24 16:24:04 CEST 2012


we have successfully used EoE with the etherlab ethercat master (stable version, from some months ago) using switch ports to form a bridge and connect to the machine running the master via ssh or to some remote machines behind another switch port - no problems, works fine.

When asking LTI what the EoE interface which shows up when their drives are connected to ethercat can be used to, they answered that one can use their control program ("Drive Manager") to configure the drive without connecting an extra ethernet cable.
So we configured it using a bridge and tried to connect to it via EoE using the IP address that it uses on its ethernet port - but I don't get an answer to pings or anything else. Sniffing on the interface with tcpdump shows nothing gets there from the servo drive, RX packets on the eoexxxx stays at 0.

Has anybody tried to configure any servo drive via ethercat? Do they perhaps/typically need to be set an IP address via one of these strange "Set IP Parameter Request" commands that the etherlab master doesn't implement? Or do they have to be sent some special command to listen on the EoE interface? Any ideas?


Georg Sassen . Software Development / Systems Administration
Fon +49 2173 8535-244 . Fax +49 2173 8535-113 . Mobile +49 171 7645851 gsassen at batalpha.com www.batalpha.com
batalpha Bobach GmbH . Raiffeisenstr. 17-18 . 40764 Langenfeld . Germany
Registry Court Düsseldorf HRB 46362 . Managing Director Max Günter Bobach

More information about the Etherlab-users mailing list