[etherlab-users] EL3403 false OP state

Janssen Matthias mjanssen at seepex.com
Thu Feb 1 11:38:03 CET 2018


Hi,

I've got a problem with the EL3403 slave.
The slave is going to the OP state successfully, but the indicator LEDs showing that a voltage phase is missing actually shows no error.
For the first test no voltage is connected, so that the LEDs should be red.

The setup:
Ethercat master up and running. (sourceforge.net commit ab97efc5513a791182eaff44b08a46f27bd1e451 and tested with the 1.5.2 (2013-02-12))
PC -> EL1818 + EL3403
No running app that uses the ethercat device.
Commandline tool ethercat is showing both slaves.
All registers can be read and set, as expected.

Setting the Operation State from INIT->PREOP->OP also works.
I tried several combinations of setting a free run mode and setting the 0x410 0x420 watchdog register to zero.
But the registers indicating a missing voltage phase does not contain the value for a missing phase, the LEDs show green.
No noise on the analog input registers, nothing.

Now what's totally weird.
I connected also my Laptop with an installed TWINCAT3 instance.
Discovered all slaves and bring them up from the INIT state to OP state and the indicator LEDs now shows the error.

I previous used several other analog and digital slaves from Beckhoff and all worked as expected.
Does anyone have an idea?


Kind regards,

Matthias Jan├čen
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.etherlab.org/pipermail/etherlab-users/attachments/20180201/01055491/attachment-0002.htm>


More information about the Etherlab-users mailing list