[etherlab-users] Etherlab Installation and Test

Pierre Letier pierre.letier at spaceapplications.com
Fri Jul 20 16:15:23 CEST 2012


I am trying to install and test the Ethercat Master and Etherlab tools. 
Here is the current installation I have :
- Ubuntu 10.04
- Patched Linux kernel ( /linux-headers-2.6.32-122-rtai downloaded from 
/ /http://www.linuxcnc.org package repository)
/- RTAI 3.9 (last version found on the RTAI repository the 07/16/2012)
- Ethercat Master 1.5.1
- Etherlab 1.3-rc3

I have two questions:
1. After the installation of Etherlab, I tried to start the service: 
"sudo /etc/init.d/etherlab start"

I receive the following message :"Starting Etherlab AppCoreinsmod: error 
inserting '/usr/realtime/modules/rtai_up.ko': -1 Invalid module format
Do you have an idea of this problem. Could it be due to the use of the 
new version of RTAI (3.9)

2. I wanted to compile a first example of process, based on the capi 
folder files (provided with Etherlab). Without modifying anything, I 
tried to "compile" with make. But I receive the following message : 
"make: Nothing to be done for 'all' "

Do you have an idea of the problem (I am missing something, I need to 
write thing somewhere in the sources) In the README file, it is said 
that we have to edit the makefile and the app_main, but mainly for the 
first file, I don't know what to change. If anybody has a complete 
example (tutorial) with inputs in the app_main, it is welcome.

Thank you

Pierre Letier
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.etherlab.org/pipermail/etherlab-users/attachments/20120720/c4546e3e/attachment-0003.htm>

More information about the Etherlab-users mailing list