[etherlab-users] configure: error: kernel 3.8 not available for 8139too driver!

Muhammad Nabeel hafiz_nabeel91 at hotmail.com
Tue Nov 5 06:24:50 CET 2013

Dear  Thomas,

Thank you for your reply,

I disable the 8139toodriver and enable generic driver then I run make command and after "make" I run "make modules" but it is giving me this error.

nabeel at ubuntu:~/ethercat-default$ make modules

make -C "/usr/src/linux-headers-3.8.0-31-generic" M="/home/nabeel/ethercat-default" modules
make[1]: Entering directory `/usr/src/linux-headers-3.8.0-31-generic'
  CC [M]  /home/nabeel/ethercat-default/master/cdev.o
/home/nabeel/ethercat-default/master/cdev.c: In function ‘ec_cdev_ioctl_slave_sdo_upload’:
/home/nabeel/ethercat-default/master/cdev.c:864:13: warning: passing argument 7 of ‘ecrt_master_sdo_upload’ from incompatible pointer type [enabled by default]
/home/nabeel/ethercat-default/master/../include/ecrt.h:758:5: note: expected ‘size_t *’ but argument is of type ‘uint32_t *’
/home/nabeel/ethercat-default/master/cdev.c: In function ‘eccdev_mmap’:
/home/nabeel/ethercat-default/master/cdev.c:3964:22: error: ‘VM_RESERVED’ undeclared (first use in this function)
/home/nabeel/ethercat-default/master/cdev.c:3964:22: note: each undeclared identifier is reported only once for each function it appears in
make[3]: *** [/home/nabeel/ethercat-default/master/cdev.o] Error 1
make[2]: *** [/home/nabeel/ethercat-default/master] Error 2
make[1]: *** [_module_/home/nabeel/ethercat-default] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.8.0-31-generic'
make: *** [modules] Error 2

Please help me how can I fix this issue, actually I am new to Ubuntu and EtherCAT that's why I am facing some problems.

Thank you.

From: tbj at automateddesign.com
To: hafiz_nabeel91 at hotmail.com
CC: etherlab-users at etherlab.org
Subject: Re: [etherlab-users] configure: error: kernel 3.8 not available for	8139too driver!
Date: Tue, 5 Nov 2013 05:07:36 +0000

On 3.8, you'll need the generic driver. There's a flag to disable the 8139too driver. It's enabled by default. You'll also need to enable the generic driver. See the PDF manual for all build flags. 

If you want to use a hardware driver (recommended), you'll need to drop down to an earlier kernel. 


(Sent from my mobile device.)

On Nov 4, 2013, at 10:51 PM, "Muhammad Nabeel" <hafiz_nabeel91 at hotmail.com> wrote:

Dear All, Hope you are doing well.

I am trying to install IgH EtherCAT master in Ubuntu 12.04, but when I run ./configuration it is giving "error configure: error: kernel 3.8 not available for 8139too driver!".

Do you have any idea how can I fix this problem?

 Thank you guys in advance.


etherlab-users mailing list

etherlab-users at etherlab.org


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.etherlab.org/pipermail/etherlab-users/attachments/20131105/7c578678/attachment-0003.htm>

More information about the Etherlab-users mailing list