[Etherlab-users] Kernel 5.x build errors

Mike O'Connor mike at oeg.com.au
Tue Jul 20 08:58:59 CEST 2021

Hi All

I'm trying to build the etherlab master on 5.4 kernel and the kernel 
module build is failing. I've also tried a 5.10 (this is a LTS version) 
with no luck.reboo

I've tried both 1.5.2 and the Gavin patch set.

Using patch set the error is below

DKMS make.log for etherlabmaster-1.5.2-patchset for kernel 
5.4.0-77-generic (x86_64)
Tue 20 Jul 2021 06:53:24 AM UTC
make[2]: Entering directory '/usr/src/linux-headers-5.4.0-77-generic'
   CC [M] 
   CC [M] /var/lib/dkms/etherlabmaster/1.5.2-patchset/build/master/cdev.o
   CC [M] 
   CC [M] 
   LD [M] 
   CC [M] 
   CC [M] 
error: initialization of ‘vm_fault_t (*)(struct vm_fault *)’ {aka 
‘unsigned int (*)(struct vm_fault *)’} from incompatible pointer type 
‘int (*)(struct vm_fault *)’ [-Werror=incompatible-pointer-types]
    91 |     .fault = eccdev_vma_fault
       |              ^~~~~~~~~~~~~~~~
note: (near initialization for ‘eccdev_vm_ops.fault’)
cc1: some warnings being treated as errors
make[4]: *** [scripts/Makefile.build:271: 
/var/lib/dkms/etherlabmaster/1.5.2-patchset/build/master/cdev.o] Error 1
make[4]: *** Waiting for unfinished jobs....
   LD [M] 
make[3]: *** [scripts/Makefile.build:518: 
/var/lib/dkms/etherlabmaster/1.5.2-patchset/build/master] Error 2
make[2]: *** [Makefile:1762: 
/var/lib/dkms/etherlabmaster/1.5.2-patchset/build] Error 2
make[2]: Leaving directory '/usr/src/linux-headers-5.4.0-77-generic'

I'm using build system from https://github.com/icshwi/etherlabmaster.

It would be very useful if a current generation kernel could compile, a 
5.x LTS kernel would great.



More information about the Etherlab-users mailing list